Back to overview
Loading panel error
May 26 at 10:31pm CEST
Affected services
GameServer panel
Resolved
May 26 at 10:31pm CEST
We had error with the panel loading because of the switch to nebula theme
Affected services
Resolved
May 26 at 10:31pm CEST
We had error with the panel loading because of the switch to nebula theme
Affected services